summaryrefslogtreecommitdiff
path: root/test/v4l2_subdevice/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/v4l2_subdevice/meson.build')
-rw-r--r--test/v4l2_subdevice/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/test/v4l2_subdevice/meson.build b/test/v4l2_subdevice/meson.build
index d82be3c6..277f29bb 100644
--- a/test/v4l2_subdevice/meson.build
+++ b/test/v4l2_subdevice/meson.build
@@ -1,14 +1,14 @@
# SPDX-License-Identifier: CC0-1.0
v4l2_subdevice_tests = [
- ['list_formats', 'list_formats.cpp'],
- ['test_formats', 'test_formats.cpp'],
+ {'name': 'list_formats', 'sources': ['list_formats.cpp']},
+ {'name': 'test_formats', 'sources': ['test_formats.cpp']},
]
-foreach t : v4l2_subdevice_tests
- exe = executable(t[0], [t[1], 'v4l2_subdevice_test.cpp'],
+foreach test : v4l2_subdevice_tests
+ exe = executable(test['name'], test['sources'], 'v4l2_subdevice_test.cpp',
dependencies : libcamera_private,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(t[0], exe, suite : 'v4l2_subdevice', is_parallel : false)
+ test(test['name'], exe, suite : 'v4l2_subdevice', is_parallel : false)
endforeach