summaryrefslogtreecommitdiff
path: root/test/py/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/py/meson.build')
-rw-r--r--test/py/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/py/meson.build b/test/py/meson.build
new file mode 100644
index 00000000..2affdbd4
--- /dev/null
+++ b/test/py/meson.build
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: CC0-1.0
+
+if not pycamera_enabled
+ subdir_done()
+endif
+
+pymod = import('python')
+py3 = pymod.find_installation('python3')
+
+pypathdir = meson.project_build_root() / 'src' / 'py'
+
+test('pyunittests',
+ py3,
+ args : files('unittests.py'),
+ env : ['PYTHONPATH=' + pypathdir],
+ suite : 'pybindings',
+ is_parallel : false)