summaryrefslogtreecommitdiff
path: root/test/process/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/process/meson.build')
-rw-r--r--test/process/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/process/meson.build b/test/process/meson.build
index c656d734..a80dc2d9 100644
--- a/test/process/meson.build
+++ b/test/process/meson.build
@@ -1,14 +1,14 @@
# SPDX-License-Identifier: CC0-1.0
process_tests = [
- ['process_test', 'process_test.cpp'],
+ {'name': 'process_test', 'sources': ['process_test.cpp']},
]
foreach test : process_tests
- exe = executable(test[0], test[1],
+ exe = executable(test['name'], test['sources'],
dependencies : libcamera_private,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(test[0], exe, suite : 'process', is_parallel : false)
+ test(test['name'], exe, suite : 'process', is_parallel : false)
endforeach