summaryrefslogtreecommitdiff
path: root/test/pipeline/rkisp1/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/pipeline/rkisp1/meson.build')
-rw-r--r--test/pipeline/rkisp1/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/pipeline/rkisp1/meson.build b/test/pipeline/rkisp1/meson.build
index c82cc789..1d178ad9 100644
--- a/test/pipeline/rkisp1/meson.build
+++ b/test/pipeline/rkisp1/meson.build
@@ -1,14 +1,14 @@
# SPDX-License-Identifier: CC0-1.0
rkisp1_test = [
- ['rkisp1_pipeline_test', 'rkisp1_pipeline_test.cpp'],
+ {'name': 'rkisp1_pipeline_test', 'sources': ['rkisp1_pipeline_test.cpp']},
]
foreach test : rkisp1_test
- exe = executable(test[0], test[1],
+ exe = executable(test['name'], test['sources'],
dependencies : libcamera_private,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(test[0], exe, suite : 'rkisp1', is_parallel : false)
+ test(test['name'], exe, suite : 'rkisp1', is_parallel : false)
endforeach