summaryrefslogtreecommitdiff
path: root/test/ipc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/ipc/meson.build')
-rw-r--r--test/ipc/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/ipc/meson.build b/test/ipc/meson.build
new file mode 100644
index 00000000..ca8375f3
--- /dev/null
+++ b/test/ipc/meson.build
@@ -0,0 +1,12 @@
+ipc_tests = [
+ [ 'unixsocket', 'unixsocket.cpp' ],
+]
+
+foreach t : ipc_tests
+ exe = executable(t[0], t[1],
+ dependencies : libcamera_dep,
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+
+ test(t[0], exe, suite : 'ipc', is_parallel : false)
+endforeach