summaryrefslogtreecommitdiff
path: root/test/ipa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/ipa/meson.build')
-rw-r--r--test/ipa/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/ipa/meson.build b/test/ipa/meson.build
index 295807fd..180b0da0 100644
--- a/test/ipa/meson.build
+++ b/test/ipa/meson.build
@@ -1,15 +1,15 @@
# SPDX-License-Identifier: CC0-1.0
ipa_test = [
- ['ipa_module_test', 'ipa_module_test.cpp'],
- ['ipa_interface_test', 'ipa_interface_test.cpp'],
+ {'name': 'ipa_module_test', 'sources': ['ipa_module_test.cpp']},
+ {'name': 'ipa_interface_test', 'sources': ['ipa_interface_test.cpp']},
]
foreach test : ipa_test
- exe = executable(test[0], [test[1], libcamera_generated_ipa_headers],
+ exe = executable(test['name'], test['sources'], libcamera_generated_ipa_headers,
dependencies : libcamera_private,
link_with : [libipa, test_libraries],
include_directories : [libipa_includes, test_includes_internal])
- test(test[0], exe, suite : 'ipa')
+ test(test['name'], exe, suite : 'ipa')
endforeach