summaryrefslogtreecommitdiff
path: root/test/ipa/libipa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/ipa/libipa/meson.build')
-rw-r--r--test/ipa/libipa/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/ipa/libipa/meson.build b/test/ipa/libipa/meson.build
index eaf4b49a..8c63ebd8 100644
--- a/test/ipa/libipa/meson.build
+++ b/test/ipa/libipa/meson.build
@@ -2,6 +2,7 @@
libipa_test = [
{'name': 'fixedpoint', 'sources': ['fixedpoint.cpp']},
+ {'name': 'histogram', 'sources': ['histogram.cpp']},
{'name': 'interpolator', 'sources': ['interpolator.cpp']},
]
@@ -13,5 +14,6 @@ foreach test : libipa_test
include_directories : [test_includes_internal,
'../../../src/ipa/libipa/'])
- test(test['name'], exe, suite : 'ipa')
+ test(test['name'], exe, suite : 'ipa',
+ should_fail : test.get('should_fail', false))
endforeach