summaryrefslogtreecommitdiff
path: root/test/controls/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/controls/meson.build')
-rw-r--r--test/controls/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/controls/meson.build b/test/controls/meson.build
new file mode 100644
index 00000000..1161864d
--- /dev/null
+++ b/test/controls/meson.build
@@ -0,0 +1,11 @@
+control_tests = [
+ [ 'control_value', 'control_value.cpp' ],
+]
+
+foreach t : control_tests
+ exe = executable(t[0], t[1],
+ dependencies : libcamera_dep,
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite : 'controls', is_parallel : false)
+endforeach