summaryrefslogtreecommitdiff
path: root/test/controls/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/controls/meson.build')
-rw-r--r--test/controls/meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/test/controls/meson.build b/test/controls/meson.build
index 0103543e..763f8905 100644
--- a/test/controls/meson.build
+++ b/test/controls/meson.build
@@ -1,16 +1,16 @@
# SPDX-License-Identifier: CC0-1.0
control_tests = [
- ['control_info', 'control_info.cpp'],
- ['control_info_map', 'control_info_map.cpp'],
- ['control_list', 'control_list.cpp'],
- ['control_value', 'control_value.cpp'],
+ {'name': 'control_info', 'sources': ['control_info.cpp']},
+ {'name': 'control_info_map', 'sources': ['control_info_map.cpp']},
+ {'name': 'control_list', 'sources': ['control_list.cpp']},
+ {'name': 'control_value', 'sources': ['control_value.cpp']},
]
-foreach t : control_tests
- exe = executable(t[0], t[1],
+foreach test : control_tests
+ exe = executable(test['name'], test['sources'],
dependencies : libcamera_public,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(t[0], exe, suite : 'controls', is_parallel : false)
+ test(test['name'], exe, suite : 'controls', is_parallel : false)
endforeach