summaryrefslogtreecommitdiff
path: root/src/v4l2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/v4l2/meson.build')
-rw-r--r--src/v4l2/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/v4l2/meson.build b/src/v4l2/meson.build
new file mode 100644
index 00000000..14ee3594
--- /dev/null
+++ b/src/v4l2/meson.build
@@ -0,0 +1,31 @@
+v4l2_compat_sources = files([
+ 'v4l2_camera.cpp',
+ 'v4l2_camera_proxy.cpp',
+ 'v4l2_compat.cpp',
+ 'v4l2_compat_manager.cpp',
+])
+
+v4l2_compat_includes = [
+ libcamera_includes,
+ libcamera_internal_includes,
+]
+
+v4l2_compat_cpp_args = [
+ # Meson enables large file support unconditionally, which redirect file
+ # operations to 64-bit versions. This results in some symbols being
+ # renamed, for instance open() being renamed to open64(). As the V4L2
+ # adaptation wrapper needs to provide both 32-bit and 64-bit versions of
+ # file operations, disable transparent large file support.
+ '-U_FILE_OFFSET_BITS',
+ '-D_FILE_OFFSET_BITS=32',
+ '-fvisibility=hidden',
+]
+
+v4l2_compat = shared_library('v4l2-compat',
+ v4l2_compat_sources,
+ name_prefix : '',
+ install : true,
+ link_with : libcamera,
+ include_directories : v4l2_compat_includes,
+ dependencies : libcamera_deps,
+ cpp_args : v4l2_compat_cpp_args)