summaryrefslogtreecommitdiff
path: root/src/v4l2/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-12-06 04:14:52 -0500
committerPaul Elder <paul.elder@ideasonboard.com>2020-01-03 19:53:20 -0500
commit0ce8f2390b5280887a2ac179faf2aa01604cb1cc (patch)
treeea8d04e9013b87217bd8266eab5356c03ded19fa /src/v4l2/meson.build
parenta3b80f3af87198b97f11f0694ff4d7ddde63fc30 (diff)
v4l2: v4l2_compat: Add V4L2 compatibility layer
Add libcamera V4L2 compatibility layer. This initial implementation supports the minimal set of V4L2 operations, which allows getting, setting, and enumerating formats, and streaming frames from a video device. Some data about the wrapped V4L2 video device are hardcoded. Add a build option named 'v4l2' and adjust the build system to selectively compile the V4L2 compatibility layer. For now we match the V4L2 device node to a libcamera camera based on a devnum that a pipeline handler may optionally map to a libcamera camera. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/v4l2/meson.build')
-rw-r--r--src/v4l2/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/v4l2/meson.build b/src/v4l2/meson.build
new file mode 100644
index 00000000..14ee3594
--- /dev/null
+++ b/src/v4l2/meson.build
@@ -0,0 +1,31 @@
+v4l2_compat_sources = files([
+ 'v4l2_camera.cpp',
+ 'v4l2_camera_proxy.cpp',
+ 'v4l2_compat.cpp',
+ 'v4l2_compat_manager.cpp',
+])
+
+v4l2_compat_includes = [
+ libcamera_includes,
+ libcamera_internal_includes,
+]
+
+v4l2_compat_cpp_args = [
+ # Meson enables large file support unconditionally, which redirect file
+ # operations to 64-bit versions. This results in some symbols being
+ # renamed, for instance open() being renamed to open64(). As the V4L2
+ # adaptation wrapper needs to provide both 32-bit and 64-bit versions of
+ # file operations, disable transparent large file support.
+ '-U_FILE_OFFSET_BITS',
+ '-D_FILE_OFFSET_BITS=32',
+ '-fvisibility=hidden',
+]
+
+v4l2_compat = shared_library('v4l2-compat',
+ v4l2_compat_sources,
+ name_prefix : '',
+ install : true,
+ link_with : libcamera,
+ include_directories : v4l2_compat_includes,
+ dependencies : libcamera_deps,
+ cpp_args : v4l2_compat_cpp_args)