summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index a4bad0a0..9bb48c0d 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -16,14 +16,14 @@ qcam_moc_headers = files([
qcam_resources = files([
'assets/feathericons/feathericons.qrc',
- 'assets/shader/shaders.qrc'
])
qt5 = import('qt5')
qt5_dep = dependency('qt5',
method : 'pkg-config',
modules : ['Core', 'Gui', 'Widgets'],
- required : get_option('qcam'))
+ required : get_option('qcam'),
+ version : '>=5.4')
if qt5_dep.found()
qcam_deps = [
@@ -42,6 +42,19 @@ if qt5_dep.found()
])
endif
+ if cxx.has_header_symbol('QOpenGLWidget', 'QOpenGLWidget',
+ dependencies : qt5_dep, args : '-fPIC')
+ qcam_sources += files([
+ 'viewfinder_gl.cpp',
+ ])
+ qcam_moc_headers += files([
+ 'viewfinder_gl.h',
+ ])
+ qcam_resources += files([
+ 'assets/shader/shaders.qrc'
+ ])
+ endif
+
# gcc 9 introduced a deprecated-copy warning that is triggered by Qt until
# Qt 5.13. clang 10 introduced the same warning, but detects more issues
# that are not fixed in Qt yet. Disable the warning manually in both cases.