summaryrefslogtreecommitdiff
path: root/src/py/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/py/libcamera/meson.build')
-rw-r--r--src/py/libcamera/meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/py/libcamera/meson.build b/src/py/libcamera/meson.build
index 1c3ea184..31af63ec 100644
--- a/src/py/libcamera/meson.build
+++ b/src/py/libcamera/meson.build
@@ -28,11 +28,15 @@ pycamera_sources = files([
# Generate controls
-gen_py_controls_input_files = files('../../libcamera/control_ids.yaml')
+gen_py_controls_input_files = []
gen_py_controls_template = files('py_controls_generated.cpp.in')
gen_py_controls = files('gen-py-controls.py')
+foreach file : controls_files
+ gen_py_controls_input_files += files('../../libcamera/' + file)
+endforeach
+
pycamera_sources += custom_target('py_gen_controls',
input : gen_py_controls_input_files,
output : ['py_controls_generated.cpp'],
@@ -41,9 +45,13 @@ pycamera_sources += custom_target('py_gen_controls',
# Generate properties
-gen_py_property_enums_input_files = files('../../libcamera/property_ids.yaml')
+gen_py_property_enums_input_files = []
gen_py_properties_template = files('py_properties_generated.cpp.in')
+foreach file : properties_files
+ gen_py_property_enums_input_files += files('../../libcamera/' + file)
+endforeach
+
pycamera_sources += custom_target('py_gen_properties',
input : gen_py_property_enums_input_files,
output : ['py_properties_generated.cpp'],