summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index b9c7e759..8e219943 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,7 +1,5 @@
# SPDX-License-Identifier: CC0-1.0
-subdir('android')
-
openssl = find_program('openssl', required : true)
if openssl.found()
ipa_priv_key = custom_target('ipa-priv-key',
@@ -13,8 +11,13 @@ else
ipa_sign_module = false
endif
+# The 'android' subdir must be processed first, and the build targets
+# are included directly into the libcamera library when this is enabled.
+subdir('android')
+
subdir('libcamera')
subdir('ipa')
+
subdir('cam')
subdir('qcam')