summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-11-10 16:03:39 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-12-30 15:31:49 +0000
commit85f01678a04663e4015ff870cd4d738de302c616 (patch)
tree447a154f8495a7d2da35a83a2e44258132cf24e4 /src/meson.build
parentbf68e722766ff0c40bd6bf73953c282c0efe4a44 (diff)
src: meson: Re-order subdir layout
Move the android subdir below the configuration options to keep all subdirs together. Add a comment explaining why android must come first, and some padding to group the libcamera and ipa components, applications, and remaining adaptation layers. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index b9c7e759..8e219943 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,7 +1,5 @@
# SPDX-License-Identifier: CC0-1.0
-subdir('android')
-
openssl = find_program('openssl', required : true)
if openssl.found()
ipa_priv_key = custom_target('ipa-priv-key',
@@ -13,8 +11,13 @@ else
ipa_sign_module = false
endif
+# The 'android' subdir must be processed first, and the build targets
+# are included directly into the libcamera library when this is enabled.
+subdir('android')
+
subdir('libcamera')
subdir('ipa')
+
subdir('cam')
subdir('qcam')