summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 1f02494a..ce1f0f2f 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -73,8 +73,14 @@ libcrypto = dependency('gnutls', required : false)
if libcrypto.found()
config_h.set('HAVE_GNUTLS', 1)
else
- libcrypto = dependency('libcrypto', required : true)
- config_h.set('HAVE_CRYPTO', 1)
+ libcrypto = dependency('libcrypto', required : false)
+ if libcrypto.found()
+ config_h.set('HAVE_CRYPTO', 1)
+ endif
+endif
+
+if not libcrypto.found()
+ warning('Neither gnutls nor libcrypto found, all IPA modules will be isolated')
endif
if liblttng.found()