summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index 07711b5f..99b27e66 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -55,6 +55,7 @@ libcamera_sources = files([
])
libcamera_sources += libcamera_public_headers
+libcamera_sources += libcamera_tracepoint_header
includes = [
libcamera_includes,
@@ -72,6 +73,11 @@ if libgnutls.found()
config_h.set('HAVE_GNUTLS', 1)
endif
+if liblttng.found()
+ config_h.set('HAVE_TRACING', 1)
+ libcamera_sources += files(['tracepoints.cpp'])
+endif
+
if libudev.found()
config_h.set('HAVE_LIBUDEV', 1)
libcamera_sources += files([
@@ -114,6 +120,7 @@ libcamera_deps = [
libatomic,
libdl,
libgnutls,
+ liblttng,
libudev,
dependency('threads'),
]