summaryrefslogtreecommitdiff
path: root/src/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/libcamera/meson.build')
-rw-r--r--src/libcamera/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
index d0e26f6b..e49bf850 100644
--- a/src/libcamera/meson.build
+++ b/src/libcamera/meson.build
@@ -127,12 +127,13 @@ endif
control_sources = []
-foreach source : control_source_files
+foreach source, mode : control_source_files
input_files = files(source +'.yaml', source + '.cpp.in')
control_sources += custom_target(source + '_cpp',
input : input_files,
output : source + '.cpp',
- command : [gen_controls, '-o', '@OUTPUT@', '@INPUT@'])
+ command : [gen_controls, '-o', '@OUTPUT@', '@INPUT@',
+ '--mode', mode])
endforeach
libcamera_sources += control_sources