summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 0 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 89320adb..39e4947f 100644
--- a/meson.build
+++ b/meson.build
@@ -178,15 +178,6 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
-# Enable the C++20 deprecated enum-enum conversion warning if the compiler
-# supports it. This helps avoiding C++20 regressions, and should be removed
-# when switching to C++20 as the warning will then be enabled by default.
-if cxx.has_argument('-Wdeprecated-enum-enum-conversion')
- cpp_arguments += [
- '-Wdeprecated-enum-enum-conversion',
- ]
-endif
-
c_arguments += common_arguments
cpp_arguments += common_arguments