summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-05-07 18:40:23 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-05-07 23:01:34 +0300
commitea1e9eba748c5a4068ba2edffebf31fb2bafa923 (patch)
treec634250e79f3aa675e3b366ed93655c5e4104849 /meson.build
parent6cd849125888782ed12af87f80a1ee9c43bcf553 (diff)
Revert "meson: Deprecate bitwise operations between different enumeration type"
Enabling -Wdeprecated-enum-enum-conversion by default turned out to be a too hasty decision. It causes compilation failures with Qt headers prior to Qt v5.15.8. As the previous LTS versions of Debian and Ubuntu ship older Qt versions, those errors cause real inconvenience to users. This reverts commit bf4695266bfca8cc21bcf10a3281e874ebce0d27. The original goal of avoiding C++20 compilation regressions is still handled through a test in CI. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 0 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 89320adb..39e4947f 100644
--- a/meson.build
+++ b/meson.build
@@ -178,15 +178,6 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
-# Enable the C++20 deprecated enum-enum conversion warning if the compiler
-# supports it. This helps avoiding C++20 regressions, and should be removed
-# when switching to C++20 as the warning will then be enabled by default.
-if cxx.has_argument('-Wdeprecated-enum-enum-conversion')
- cpp_arguments += [
- '-Wdeprecated-enum-enum-conversion',
- ]
-endif
-
c_arguments += common_arguments
cpp_arguments += common_arguments