summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a49c484f..4a10e2b6 100644
--- a/meson.build
+++ b/meson.build
@@ -108,6 +108,10 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
+# Do not warn when a function declaration hides virtual functions from
+# a base class
+cpp_arguments += '-Wno-overloaded-virtual'
+
c_arguments += common_arguments
cpp_arguments += common_arguments