summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-08-19 09:03:11 +0200
committerJean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com>2021-08-20 12:11:28 +0200
commitb3a2882b36db009baf473f1a45b4beee929fbb55 (patch)
tree72ccd2ce3daccc7aaa92cd0be08f7afc874ebb49 /meson.build
parenta35eb4b36f986b4390865bb4d58bb110ec955fba (diff)
ipa: ipu3: Add the functions to the Algorithm class
Introduce three functions in the Algorithm class to manage algorithms: - configure which is called when IPA is configured only - prepare called on EventFillParams event at each frame when the request is queued - process called on EventStatReady event at each frame completion when the statistics have been generated. The existing AGC implementation already has a function named process(), though it has different arguments. Adding the new virtual process() interface causes a compiler warning due to the AGC implementation overloading a virtual function, even though the overload can be resolved correctly. Temporarily disable the warning in this commit to maintain bisection until the AGC is converted to the new interface. Signed-off-by: Jean-Michel Hautbois <jeanmichel.hautbois@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a49c484f..4a10e2b6 100644
--- a/meson.build
+++ b/meson.build
@@ -108,6 +108,10 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
+# Do not warn when a function declaration hides virtual functions from
+# a base class
+cpp_arguments += '-Wno-overloaded-virtual'
+
c_arguments += common_arguments
cpp_arguments += common_arguments