summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0ab0da98..4465a385 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,11 @@
project('libcamera', 'c', 'cpp',
meson_version: '>= 0.40',
version : '0.1',
+ default_options: [
+ 'werror=true',
+ 'warning_level=2',
+ 'cpp_std=c++11',
+ ],
license : 'LGPL 2.1+')
# TODO: Extract this from project.version.
@@ -9,15 +14,11 @@ project('libcamera', 'c', 'cpp',
api_version = '0.1'
common_arguments = [
- '-Wall',
- '-Wextra',
- '-Werror',
'-Wno-unused-parameter',
]
c_arguments = common_arguments
cpp_arguments = common_arguments
-cpp_arguments += '-std=c++11'
add_project_arguments(c_arguments, language: 'c')
add_project_arguments(cpp_arguments, language: 'cpp')