summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-01-07 14:22:30 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-01-15 21:14:35 +0000
commita5e86d4396ae7221e431a748559e56a8d024e43e (patch)
tree8b21f2c98a423ad734cda63ad213570f8e849edc /meson.build
parentf1caaaf387dd707a6bcdd2216ba74813398fe82d (diff)
meson: Utilise default compiler options
Remove our custom declarations for cpp_std=c++11, -Wall, -Wextra and -Werror, instead prefering to use the built-in default_option parameters from meson. Our custom compiler flags (such as -Wno-unused-parameter) are maintained. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0ab0da98..4465a385 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,11 @@
project('libcamera', 'c', 'cpp',
meson_version: '>= 0.40',
version : '0.1',
+ default_options: [
+ 'werror=true',
+ 'warning_level=2',
+ 'cpp_std=c++11',
+ ],
license : 'LGPL 2.1+')
# TODO: Extract this from project.version.
@@ -9,15 +14,11 @@ project('libcamera', 'c', 'cpp',
api_version = '0.1'
common_arguments = [
- '-Wall',
- '-Wextra',
- '-Werror',
'-Wno-unused-parameter',
]
c_arguments = common_arguments
cpp_arguments = common_arguments
-cpp_arguments += '-std=c++11'
add_project_arguments(c_arguments, language: 'c')
add_project_arguments(cpp_arguments, language: 'cpp')