summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9fc5cc52..6c571a17 100644
--- a/meson.build
+++ b/meson.build
@@ -69,6 +69,16 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
+# gcc 7.1 introduced processor-specific ABI breakages related to parameter
+# passing on ARM platforms. This generates a large number of messages during
+# compilation with gcc >=7.1 until gcc 9. Silence them.
+if (host_machine.cpu_family() == 'arm' and cc.get_id() == 'gcc' and
+ cc.version().version_compare('>=7.1') and cc.version().version_compare('<9'))
+ cpp_arguments += [
+ '-Wno-psabi',
+ ]
+endif
+
c_arguments += common_arguments
cpp_arguments += common_arguments