summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-01 01:51:07 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-05-01 17:51:59 +0300
commit1c883def04bdb22a2c8a2ed9b0e72f85a744fa2b (patch)
tree82af80636b4bc17610fb5c3f4f5597112e6f50cd /meson.build
parentdee99d47267e9d9204884b2ff798cd02eb5914f2 (diff)
libcamera: Set -Wno-psabi on gcc 7 and 8 for arm
gcc 7.1 introduced processor-specific ABI breakages related to parameter passing on ARM platforms. This generates a large number of messages during compilation with gcc >=7.1 until gcc 9. Silence them. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9fc5cc52..6c571a17 100644
--- a/meson.build
+++ b/meson.build
@@ -69,6 +69,16 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
+# gcc 7.1 introduced processor-specific ABI breakages related to parameter
+# passing on ARM platforms. This generates a large number of messages during
+# compilation with gcc >=7.1 until gcc 9. Silence them.
+if (host_machine.cpu_family() == 'arm' and cc.get_id() == 'gcc' and
+ cc.version().version_compare('>=7.1') and cc.version().version_compare('<9'))
+ cpp_arguments += [
+ '-Wno-psabi',
+ ]
+endif
+
c_arguments += common_arguments
cpp_arguments += common_arguments