summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d02f9917..df9099d0 100644
--- a/meson.build
+++ b/meson.build
@@ -164,6 +164,23 @@ liblttng = dependency('lttng-ust', required : get_option('tracing'))
# are enabled.
pipelines = get_option('pipelines')
+if pipelines.contains('auto')
+ host_cpu = host_machine.cpu_family()
+ pipelines = []
+ if host_cpu == 'x86' or host_cpu == 'x86_64'
+ pipelines += ['ipu3']
+ elif host_cpu == 'aarch64'
+ pipelines += ['imx8-isi', 'rkisp1']
+ endif
+
+ if host_cpu == 'arm' or host_cpu == 'aarch64'
+ pipelines += ['raspberrypi', 'simple']
+ endif
+
+ # Always include the uvcvideo pipeline handler.
+ pipelines += ['uvcvideo']
+endif
+
if get_option('test') and 'vimc' not in pipelines
message('Enabling vimc pipeline handler to support tests')
pipelines += ['vimc']