summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 33afbb74..5270f626 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@
project('libcamera', 'c', 'cpp',
meson_version : '>= 0.63',
- version : '0.3.2',
+ version : '0.4.0',
default_options : [
'werror=true',
'warning_level=2',
@@ -204,7 +204,7 @@ liblttng = dependency('lttng-ust', required : get_option('tracing'))
# Pipeline handlers
#
-pipelines = get_option('pipelines')
+wanted_pipelines = get_option('pipelines')
arch_arm = ['arm', 'aarch64']
arch_x86 = ['x86', 'x86_64']
@@ -220,16 +220,18 @@ pipelines_support = {
'virtual': ['test'],
}
-if pipelines.contains('all')
+if wanted_pipelines.contains('all')
pipelines = pipelines_support.keys()
-elif pipelines.contains('auto')
+elif wanted_pipelines.contains('auto')
host_cpu = host_machine.cpu_family()
pipelines = []
foreach pipeline, archs : pipelines_support
- if host_cpu in archs or 'any' in archs
+ if pipeline in wanted_pipelines or host_cpu in archs or 'any' in archs
pipelines += pipeline
endif
endforeach
+else
+ pipelines = wanted_pipelines
endif
# Tests require the vimc pipeline handler, include it automatically when tests