summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build162
1 files changed, 136 insertions, 26 deletions
diff --git a/meson.build b/meson.build
index 6d7d3ca6..89320adb 100644
--- a/meson.build
+++ b/meson.build
@@ -1,8 +1,8 @@
# SPDX-License-Identifier: CC0-1.0
project('libcamera', 'c', 'cpp',
- meson_version : '>= 0.56',
- version : '0.0.0',
+ meson_version : '>= 0.60',
+ version : '0.2.0',
default_options : [
'werror=true',
'warning_level=2',
@@ -11,22 +11,62 @@ project('libcamera', 'c', 'cpp',
license : 'LGPL 2.1+')
# Generate version information. The libcamera_git_version variable contains the
-# full version with git patch count and SHA1 (e.g. 1.2.3+211-c94a24f4), while
-# the libcamera_version variable contains the major.minor.patch (e.g. 1.2.3)
-# only. If the source tree isn't under git control, or if it matches the last
-# git version tag, the build metadata (e.g. +211-c94a24f4) is omitted from
-# libcamera_git_version.
+# full version with build metadata (patch count and SHA1, e.g.
+# 1.2.3+211-c94a24f4), while the libcamera_version variable contains the
+# major.minor.patch (e.g. 1.2.3) only.
+#
+# If the source tree matches the last git version tag, the build metadata
+# (e.g. +211-c94a24f4) is omitted from libcamera_git_version.
libcamera_git_version = run_command('utils/gen-version.sh',
meson.project_build_root(),
meson.project_source_root(),
- check: false).stdout().strip()
+ check : false).stdout().strip()
+
+# If the source tree isn't under git control, set libcamera_git_version to the
+# meson project version.
if libcamera_git_version == ''
libcamera_git_version = meson.project_version()
endif
libcamera_version = libcamera_git_version.split('+')[0]
+project_version = meson.project_version().split('+')[0]
+
+# A shallow clone, or a clone without a reachable tag equivalent to the
+# meson.project_version() could leave the project in a mis-described state.
+# Produce a warning in this event, and fix to a best effort.
+if libcamera_version != project_version
+ warning('The sources and meson.build disagree about the version: '
+ + libcamera_version + ' != ' + project_version)
+
+ summary({'libcamera git version' : libcamera_git_version,
+ 'Source version match' : false,
+ },
+ bool_yn : true, section : 'Versions')
+
+ # Re-run gen-version.sh to replace the git version (major.minor.patch) with
+ # the meson project version. The build metadata provided by git are kept.
+ libcamera_git_version = run_command('utils/gen-version.sh',
+ meson.project_build_root(),
+ meson.project_source_root(),
+ project_version,
+ check : false).stdout().strip()
+ libcamera_version = project_version
+
+ # Append a marker to show we have modified this version string.
+ libcamera_git_version += '-nvm'
+endif
-# This script gererates the .tarball-version file on a 'meson dist' command.
+# The major and minor libcamera version components are used as the soname.
+# No ABI/API compatibility is guaranteed between releases (x.y).
+#
+# When we declare a stable ABI/API we will provide a 1.0 release and the
+# soversion at that point will be the 'major' release value (x).
+semver = libcamera_version.split('.')
+libcamera_soversion = semver[0] + '.' + semver[1]
+
+summary({ 'Sources': libcamera_git_version, }, section : 'Versions')
+
+# This script generates the .tarball-version file on a 'meson dist' command.
meson.add_dist_script('utils/run-dist.sh')
# Configure the build environment.
@@ -38,13 +78,21 @@ if cc.has_header_symbol('unistd.h', 'issetugid')
config_h.set('HAVE_ISSETUGID', 1)
endif
+if cc.has_header_symbol('locale.h', 'locale_t', prefix : '#define _GNU_SOURCE')
+ config_h.set('HAVE_LOCALE_T', 1)
+endif
+
+if cc.has_header_symbol('sys/mman.h', 'memfd_create', prefix : '#define _GNU_SOURCE')
+ config_h.set('HAVE_MEMFD_CREATE', 1)
+endif
+
if cc.has_header_symbol('stdlib.h', 'secure_getenv', prefix : '#define _GNU_SOURCE')
config_h.set('HAVE_SECURE_GETENV', 1)
endif
common_arguments = [
'-Wshadow',
- '-include', 'config.h',
+ '-include', meson.current_build_dir() / 'config.h',
]
c_arguments = []
@@ -55,17 +103,23 @@ if cc.get_id() == 'clang'
error('clang version is too old, libcamera requires 9.0 or newer')
endif
- # Turn _FORTIFY_SOURCE by default on optimised builds (as it requires -O1
- # or higher). This is needed on clang only as gcc enables it by default.
+ # Turn _FORTIFY_SOURCE by default on. This is needed on clang only as gcc
+ # enables it by default. FORTIFY will not work properly with `-O0`, and may
+ # result in macro redefinition errors if the user already has a setting for
+ # `-D_FORTIFY_SOURCE`. Do not enable FORTIFY in either of those cases.
if get_option('optimization') != '0'
- common_arguments += [
- '-D_FORTIFY_SOURCE=2',
- ]
+ fortify = cc.get_define('_FORTIFY_SOURCE')
+ if fortify == ''
+ message('Adding _FORTIFY_SOURCE')
+ common_arguments += [
+ '-D_FORTIFY_SOURCE=2',
+ ]
+ endif
endif
# Use libc++ by default if available instead of libstdc++ when compiling
# with clang.
- if cc.find_library('libc++', required: false).found()
+ if cc.find_library('c++', required : false).found()
cpp_arguments += [
'-stdlib=libc++',
]
@@ -90,6 +144,21 @@ if cc.get_id() == 'gcc'
]
endif
+ # gcc 13 implements the C++23 version of automatic move from local
+ # variables in return statements (see
+ # https://en.cppreference.com/w/cpp/language/return). As a result, some
+ # previously required explicit std::move() in return statements generate
+ # warnings. Those moves can't be removed as older compiler versions could
+ # use copy constructors instead of move constructors. The easiest fix is to
+ # disable the warning. With -Wpessimizing-move enabled, the compiler will
+ # still warn of pessimizing moves, only the redundant but not pessimizing
+ # moves will be ignored.
+ if cc.version().version_compare('>=13')
+ cpp_arguments += [
+ '-Wno-redundant-move',
+ ]
+ endif
+
# gcc 7.1 introduced processor-specific ABI breakages related to parameter
# passing on ARM platforms. This generates a large number of messages
# during compilation. Silence them.
@@ -109,6 +178,15 @@ if cc.has_argument('-Wno-c99-designator')
]
endif
+# Enable the C++20 deprecated enum-enum conversion warning if the compiler
+# supports it. This helps avoiding C++20 regressions, and should be removed
+# when switching to C++20 as the warning will then be enabled by default.
+if cxx.has_argument('-Wdeprecated-enum-enum-conversion')
+ cpp_arguments += [
+ '-Wdeprecated-enum-enum-conversion',
+ ]
+endif
+
c_arguments += common_arguments
cpp_arguments += common_arguments
@@ -122,17 +200,46 @@ libcamera_includes = include_directories('include')
py_modules = []
# Libraries used by multiple components
-liblttng = cc.find_library('lttng-ust', required : get_option('tracing'))
+liblttng = dependency('lttng-ust', required : get_option('tracing'))
# Pipeline handlers
#
-# Tests require the vimc pipeline handler, include it automatically when tests
-# are enabled.
pipelines = get_option('pipelines')
-if get_option('test') and 'vimc' not in pipelines
- message('Enabling vimc pipeline handler to support tests')
- pipelines += ['vimc']
+arch_arm = ['arm', 'aarch64']
+arch_x86 = ['x86', 'x86_64']
+pipelines_support = {
+ 'imx8-isi': arch_arm,
+ 'ipu3': arch_x86,
+ 'mali-c55': arch_arm,
+ 'rkisp1': arch_arm,
+ 'rpi/vc4': arch_arm,
+ 'simple': arch_arm,
+ 'uvcvideo': ['any'],
+ 'vimc': ['test'],
+}
+
+if pipelines.contains('all')
+ pipelines = pipelines_support.keys()
+elif pipelines.contains('auto')
+ host_cpu = host_machine.cpu_family()
+ pipelines = []
+ foreach pipeline, archs : pipelines_support
+ if host_cpu in archs or 'any' in archs
+ pipelines += pipeline
+ endif
+ endforeach
+endif
+
+# Tests require the vimc pipeline handler, include it automatically when tests
+# are enabled.
+if get_option('test')
+ foreach pipeline, archs : pipelines_support
+ if 'test' in archs and pipeline not in pipelines
+ message('Enabling ' + pipeline + ' pipeline handler for tests')
+ pipelines += pipeline
+ endif
+ endforeach
endif
# Utilities are parsed first to provide support for other components.
@@ -149,7 +256,7 @@ subdir('test')
if not meson.is_cross_build()
kernel_version_req = '>= 5.0.0'
- kernel_version = run_command('uname', '-r', check: true).stdout().strip()
+ kernel_version = run_command('uname', '-r', check : true).stdout().strip()
if not kernel_version.version_compare(kernel_version_req)
warning('The current running kernel version @0@ is too old to run libcamera.'
.format(kernel_version))
@@ -162,18 +269,21 @@ endif
# running libcamera from the build directory to locate resources in the source
# directory (such as IPA configuration files).
run_command('ln', '-fsT', meson.project_source_root(), meson.project_build_root() / 'source',
- check: true)
+ check : true)
configure_file(output : 'config.h', configuration : config_h)
# Check for python installation and modules.
py_mod = import('python')
-py_mod.find_installation('python3', modules: py_modules)
+py_mod.find_installation('python3', modules : py_modules)
## Summarise Configurations
summary({
'Enabled pipelines': pipelines,
- 'Enabled IPA modules': ipa_modules,
+ 'Enabled IPA modules': enabled_ipa_names,
+ 'Controls files': controls_files,
+ 'Properties files': properties_files,
+ 'Hotplug support': libudev.found(),
'Tracing support': tracing_enabled,
'Android support': android_enabled,
'GStreamer support': gst_enabled,