summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index 3067120a..6f81f111 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -16,6 +16,13 @@ libcamera_api = files([
'timer.h',
])
+gen_version = join_paths(meson.source_root(), 'utils', 'gen-version.sh')
+
+version_h = vcs_tag(command : [gen_version, meson.current_source_dir()],
+ input : 'version.h.in',
+ output : 'version.h',
+ fallback : 'v0.0')
+
gen_header = files('gen-header.sh')
libcamera_h = custom_target('gen-header',