summaryrefslogtreecommitdiff
path: root/include/libcamera/internal/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'include/libcamera/internal/meson.build')
-rw-r--r--include/libcamera/internal/meson.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/include/libcamera/internal/meson.build b/include/libcamera/internal/meson.build
new file mode 100644
index 00000000..1f6af579
--- /dev/null
+++ b/include/libcamera/internal/meson.build
@@ -0,0 +1,35 @@
+# SPDX-License-Identifier: CC0-1.0
+
+libcamera_headers = files([
+ 'byte_stream_buffer.h',
+ 'camera_controls.h',
+ 'camera_sensor.h',
+ 'control_serializer.h',
+ 'control_validator.h',
+ 'device_enumerator.h',
+ 'device_enumerator_sysfs.h',
+ 'device_enumerator_udev.h',
+ 'event_dispatcher_poll.h',
+ 'file.h',
+ 'formats.h',
+ 'ipa_context_wrapper.h',
+ 'ipa_manager.h',
+ 'ipa_module.h',
+ 'ipa_proxy.h',
+ 'ipc_unixsocket.h',
+ 'log.h',
+ 'media_device.h',
+ 'media_object.h',
+ 'message.h',
+ 'pipeline_handler.h',
+ 'process.h',
+ 'pub_key.h',
+ 'semaphore.h',
+ 'thread.h',
+ 'utils.h',
+ 'v4l2_controls.h',
+ 'v4l2_device.h',
+ 'v4l2_pixelformat.h',
+ 'v4l2_subdevice.h',
+ 'v4l2_videodevice.h',
+])