summaryrefslogtreecommitdiff
path: root/Documentation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index 629e8531..2db80b39 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -1,4 +1,4 @@
-doc_install_dir = join_paths(get_option('datadir'), 'doc', 'libcamera-@0@'.format(api_version))
+doc_install_dir = join_paths(get_option('datadir'), 'doc', 'libcamera-@0@'.format(meson.project_version()))
#
# Doxygen
@@ -47,8 +47,11 @@ if sphinx.found()
'index.rst',
]
+ release = 'release=' + meson.project_version()
+
custom_target('documentation',
- command : [sphinx, '-q', '-W', '-b', 'html', meson.current_source_dir(), '@OUTPUT@'],
+ command : [sphinx, '-D', release, '-q', '-W', '-b', 'html',
+ meson.current_source_dir(), '@OUTPUT@'],
input : docs_sources,
output : 'html',
build_by_default : true,