summaryrefslogtreecommitdiff
path: root/Documentation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build25
1 files changed, 19 insertions, 6 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index 7695bcb1..3872e0a8 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -14,6 +14,14 @@ if doxygen.found() and dot.found()
cdata.set('VERSION', 'v@0@'.format(libcamera_git_version))
cdata.set('TOP_SRCDIR', meson.project_source_root())
cdata.set('TOP_BUILDDIR', meson.project_build_root())
+ cdata.set('OUTPUT_DIR', meson.current_build_dir())
+
+ doxygen_predefined = []
+ foreach key : config_h.keys()
+ doxygen_predefined += '@0@=@1@'.format(key, config_h.get(key))
+ endforeach
+
+ cdata.set('PREDEFINED', ' \\\n\t\t\t '.join(doxygen_predefined))
doxyfile = configure_file(input : 'Doxyfile.in',
output : 'Doxyfile',
@@ -41,7 +49,8 @@ if doxygen.found() and dot.found()
output : 'api-html',
command : [doxygen, doxyfile],
install : true,
- install_dir : doc_install_dir)
+ install_dir : doc_install_dir,
+ install_tag : 'doc')
endif
#
@@ -55,6 +64,8 @@ endif
if sphinx.found()
docs_sources = [
+ 'camera-sensor-model.rst',
+ 'code-of-conduct.rst',
'coding-style.rst',
'conf.py',
'contributing.rst',
@@ -69,6 +80,7 @@ if sphinx.found()
'lens_driver_requirements.rst',
'python-bindings.rst',
'sensor_driver_requirements.rst',
+ 'software-isp-benchmarking.rst',
'../README.rst',
]
@@ -81,11 +93,12 @@ if sphinx.found()
output : 'html',
build_by_default : true,
install : true,
- install_dir : doc_install_dir)
+ install_dir : doc_install_dir,
+ install_tag : 'doc')
custom_target('documentation-linkcheck',
- command: [sphinx, '-W', '-b', 'linkcheck', meson.current_source_dir(), '@OUTPUT@'],
- build_always_stale: true,
- input: docs_sources,
- output: 'linkcheck')
+ command : [sphinx, '-W', '-b', 'linkcheck', meson.current_source_dir(), '@OUTPUT@'],
+ build_always_stale : true,
+ input : docs_sources,
+ output : 'linkcheck')
endif