summaryrefslogtreecommitdiff
path: root/utils/ipc/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2021-05-24 16:46:42 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2021-05-27 17:07:04 +0900
commitbd06b648fb1c7b0a137f23f15cd5e72c5edd881a (patch)
tree237d422df2b9479a14923b33c5bc96faa391f45b /utils/ipc/meson.build
parent6c5f3fe6ced796eb396926a22394a45724e02fef (diff)
utils: ipc: Add script to extract doxygen docs from mojom files
Add a script to extract doxygen documentation comments from mojom files. It matches based on ^\/\*\*$ for start of block and ^ \*\/$ for end of block, and simply copies the comments to the output file along with a header and the libcamera namespace. Also add it to the meson file so it is usable by other meson files. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Acked-by: Umang Jain <umang.jain@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'utils/ipc/meson.build')
-rw-r--r--utils/ipc/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/utils/ipc/meson.build b/utils/ipc/meson.build
index 4a41b9c1..973a5417 100644
--- a/utils/ipc/meson.build
+++ b/utils/ipc/meson.build
@@ -8,6 +8,8 @@ mojom_parser = find_program('./parser.py')
mojom_generator = find_program('./generate.py')
+mojom_docs_extractor = find_program('./extract-docs.py')
+
mojom_templates = custom_target('mojom_templates',
input : mojom_template_files,
output : 'libcamera_templates.zip',