summaryrefslogtreecommitdiff
path: root/test/v4l2_videodevice/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-02-16 17:03:34 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-03-06 17:45:48 +0100
commit69d1e24ac75dc4003737b926bee3ce05420d047b (patch)
treeadcf3bd813c295b84a063e432fe5473dba7ed4f6 /test/v4l2_videodevice/meson.build
parentb167158395e9238de99c1b6e5dac4f7394341df5 (diff)
test: v4l2_videodevice: Add test for V4L2BufferCache
Add test to test the different modes and situations the V4L2BufferCache can be put in. The tests verify that a FrameBuffer used with the cache results in a V4L2 video device index, and that the cache implementation is capable of keeping buffers in a hot state. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/v4l2_videodevice/meson.build')
-rw-r--r--test/v4l2_videodevice/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/v4l2_videodevice/meson.build b/test/v4l2_videodevice/meson.build
index 5c52da72..685fcf6d 100644
--- a/test/v4l2_videodevice/meson.build
+++ b/test/v4l2_videodevice/meson.build
@@ -5,6 +5,7 @@ v4l2_videodevice_tests = [
[ 'controls', 'controls.cpp' ],
[ 'formats', 'formats.cpp' ],
[ 'request_buffers', 'request_buffers.cpp' ],
+ [ 'buffer_cache', 'buffer_cache.cpp' ],
[ 'stream_on_off', 'stream_on_off.cpp' ],
[ 'capture_async', 'capture_async.cpp' ],
[ 'buffer_sharing', 'buffer_sharing.cpp' ],