summaryrefslogtreecommitdiff
path: root/test/v4l2_videodevice/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-08-08 15:06:31 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-08-13 15:36:04 +0100
commit093573db19179b5bb5e728afe87bd3a610447112 (patch)
tree7663e75354c67ce6e1afbbc7ffa02c6157b88326 /test/v4l2_videodevice/meson.build
parent4f7625cca7ecb4ae5257e7e65ad86d046568db51 (diff)
test: v4l2_videodevice: Add M2M device test
The V4L2M2MDevice requires two video devices to be configured. This makes it unsuitable to reuse the existing V4L2DeviceTest test library in its current form. Implement a full test to run the two M2M pipelines through VIM2M. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/v4l2_videodevice/meson.build')
-rw-r--r--test/v4l2_videodevice/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/v4l2_videodevice/meson.build b/test/v4l2_videodevice/meson.build
index 76be5e14..ad41898b 100644
--- a/test/v4l2_videodevice/meson.build
+++ b/test/v4l2_videodevice/meson.build
@@ -7,6 +7,7 @@ v4l2_videodevice_tests = [
[ 'stream_on_off', 'stream_on_off.cpp' ],
[ 'capture_async', 'capture_async.cpp' ],
[ 'buffer_sharing', 'buffer_sharing.cpp' ],
+ [ 'v4l2_m2mdevice', 'v4l2_m2mdevice.cpp' ],
]
foreach t : v4l2_videodevice_tests