summaryrefslogtreecommitdiff
path: root/test/v4l2_subdevice/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-02-12 23:21:16 +0100
committerJacopo Mondi <jacopo@jmondi.org>2019-03-01 12:33:17 +0100
commit7f4ce94ad9e14fa4fd53644abb2ce2bb2bf03dc3 (patch)
treefc7f6fd2cf7256f10fc23986a6ec2ca67a7ea2e9 /test/v4l2_subdevice/meson.build
parenta56f8a57b554e97116086a1d4078f7462e068486 (diff)
test: v4l2_subdevice: Add format handling test
Add test for video format get and set operations on V4L2Subdevice class. Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/v4l2_subdevice/meson.build')
-rw-r--r--test/v4l2_subdevice/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/v4l2_subdevice/meson.build b/test/v4l2_subdevice/meson.build
new file mode 100644
index 00000000..f45dca0d
--- /dev/null
+++ b/test/v4l2_subdevice/meson.build
@@ -0,0 +1,10 @@
+v4l2_subdevice_tests = [
+ [ 'test_formats', 'test_formats.cpp'],
+]
+
+foreach t : v4l2_subdevice_tests
+ exe = executable(t[0], [t[1], 'v4l2_subdevice_test.cpp'],
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite: 'v4l2_subdevice', is_parallel: false)
+endforeach