summaryrefslogtreecommitdiff
path: root/test/v4l2_device/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-01-24 17:48:10 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-02-06 06:49:43 +0200
commitba4dfa74714785005232e4268d63df1a4f162e24 (patch)
tree0054bfb5deaf5d9a4e21a50abba58cc272c07633 /test/v4l2_device/meson.build
parentd2046d863b950791e749d2b22d66b2e5007c146e (diff)
test: v4l2_device: Provide asynchronous capture test
Utilise the event_dispatcher to create a default event loop, and process asynchronous buffer receive events. If no frames are captured in 5 seconds, the test will fail. It will also fail if less than 30 frames have been captured in the same timeout period. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/v4l2_device/meson.build')
-rw-r--r--test/v4l2_device/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/v4l2_device/meson.build b/test/v4l2_device/meson.build
index cbaa79da..ec2c7f9f 100644
--- a/test/v4l2_device/meson.build
+++ b/test/v4l2_device/meson.build
@@ -4,6 +4,7 @@ v4l2_device_tests = [
[ 'double_open', 'double_open.cpp' ],
[ 'request_buffers', 'request_buffers.cpp' ],
[ 'stream_on_off', 'stream_on_off.cpp' ],
+ [ 'capture_async', 'capture_async.cpp' ],
]
foreach t : v4l2_device_tests