summaryrefslogtreecommitdiff
path: root/test/v4l2_device/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-01-08 14:00:24 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-01-17 21:55:27 +0000
commit479264dfcaca61f08a0609db584d11d8fb252103 (patch)
treefdce766a28cb3e1814e10e890362d5790028db98 /test/v4l2_device/meson.build
parente74f3eebb498634f438a005b2ad5b7f1778091e8 (diff)
test: v4l2_device: Add test suite and initial test
Provide a base class to construct a v4l2_device object for further tests and an initial test which validates the FD handle can not be leaked. Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/v4l2_device/meson.build')
-rw-r--r--test/v4l2_device/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/v4l2_device/meson.build b/test/v4l2_device/meson.build
new file mode 100644
index 00000000..41675a30
--- /dev/null
+++ b/test/v4l2_device/meson.build
@@ -0,0 +1,12 @@
+# Tests are listed in order of complexity.
+# They are not alphabetically sorted.
+v4l2_device_tests = [
+ [ 'double_open', 'double_open.cpp' ],
+]
+
+foreach t : v4l2_device_tests
+ exe = executable(t[0], [t[1], 'v4l2_device_test.cpp'],
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite: 'v4l2_device', is_parallel: false)
+endforeach