summaryrefslogtreecommitdiff
path: root/test/v4l2_device/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-02-07 10:37:33 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-02-13 17:32:31 +0000
commit220106b1fe32518c2c7fe7a9609638d957cd240f (patch)
tree6d5922f2e8d6f110ec4eafd0faac8ac525b952b3 /test/v4l2_device/meson.build
parent9cee8620c3ef75ae8c3511922add4e2607628d7c (diff)
test: v4l2_device: Provide buffer sharing test
Obtain two V4L2Devices and use one to obtain a BufferPool. Propagate the formats from the first to the second device and then commence sending buffers between the two devices in a ping-pong fashion. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/v4l2_device/meson.build')
-rw-r--r--test/v4l2_device/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/v4l2_device/meson.build b/test/v4l2_device/meson.build
index ec2c7f9f..9f7a7545 100644
--- a/test/v4l2_device/meson.build
+++ b/test/v4l2_device/meson.build
@@ -5,6 +5,7 @@ v4l2_device_tests = [
[ 'request_buffers', 'request_buffers.cpp' ],
[ 'stream_on_off', 'stream_on_off.cpp' ],
[ 'capture_async', 'capture_async.cpp' ],
+ [ 'buffer_sharing', 'buffer_sharing.cpp' ],
]
foreach t : v4l2_device_tests