summaryrefslogtreecommitdiff
path: root/test/v4l2_compat/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2020-06-19 21:53:39 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2020-07-10 16:11:53 +0900
commite37e72c61c1021c1a19e031066c11569f948d9d2 (patch)
treedb10d317c265f7ca3f3c2993e92b9ffbc7b6c53e /test/v4l2_compat/meson.build
parent323a53c2329fe70a063b2d479b19385d10e0a559 (diff)
tests: v4l2_compat: Add test for v4l2_compat
Test the V4L2 compatibility layer by running v4l2-compliance -s on every /dev/video* device. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/v4l2_compat/meson.build')
-rw-r--r--test/v4l2_compat/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/v4l2_compat/meson.build b/test/v4l2_compat/meson.build
new file mode 100644
index 00000000..5b29de7c
--- /dev/null
+++ b/test/v4l2_compat/meson.build
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: CC0-1.0
+
+if is_variable('v4l2_compat')
+ v4l2_compat_test = files('v4l2_compat_test.py')
+
+ test('v4l2_compat_test', v4l2_compat_test,
+ args : v4l2_compat,
+ suite : 'v4l2_compat',
+ timeout : 60)
+endif