summaryrefslogtreecommitdiff
path: root/test/stream/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-04-30 20:28:31 +0200
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-06-19 12:25:12 +0200
commit5ed3a89480b5330e0032c13ba6edb2adcf5c3e7a (patch)
treef91f2531d412d0bf579043db8608a29cc7dbd06f /test/stream/meson.build
parenta50289642948239722b0f45b2df097df20d43ae9 (diff)
test: stream: Add test for StreamFormat
Test that both discrete and range based stream format descriptions result in good discrete frame sizes. The range based stream formats needs to be fitted with a table of resolutions inside libcamera so if that table is updated this test might need to be updated. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/stream/meson.build')
-rw-r--r--test/stream/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/stream/meson.build b/test/stream/meson.build
new file mode 100644
index 00000000..2f2493de
--- /dev/null
+++ b/test/stream/meson.build
@@ -0,0 +1,11 @@
+stream_tests = [
+ [ 'stream_formats', 'stream_formats.cpp' ],
+]
+
+foreach t : stream_tests
+ exe = executable(t[0], t[1],
+ dependencies : libcamera_dep,
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+ test(t[0], exe, suite: 'stream', is_parallel: false)
+endforeach