summaryrefslogtreecommitdiff
path: root/test/media_device/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-04-29 19:29:35 +0200
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-05-17 20:35:09 +0200
commit9c1fe51ebc33684a2205dfb92dde469f436c855c (patch)
tree5e492963bc10daebca475e6b6f8d0ccc3d3b05f5 /test/media_device/meson.build
parent9654d1f64a216214304706802fab19a71eaf5cf1 (diff)
test: media_device: Add test for acquire() and release()
The interfaces MediaDevice::{open,close}() are about to be made private, replace them with a test of MediaDevice::{acquire,release}() instead. The new test will implicitly tests the open() and close() methods as they are about to be move inside acquire() and release() which will remain public. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/media_device/meson.build')
-rw-r--r--test/media_device/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/media_device/meson.build b/test/media_device/meson.build
index 42913113..7ac6c2db 100644
--- a/test/media_device/meson.build
+++ b/test/media_device/meson.build
@@ -3,6 +3,7 @@ lib_mdev_test_sources = files([
])
media_device_tests = [
+ ['media_device_acquire', 'media_device_acquire.cpp'],
['media_device_print_test', 'media_device_print_test.cpp'],
['media_device_link_test', 'media_device_link_test.cpp'],
]