summaryrefslogtreecommitdiff
path: root/test/ipa/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-05-10 19:10:41 -0400
committerPaul Elder <paul.elder@ideasonboard.com>2019-05-21 18:35:11 -0400
commitd8de003a0482c998c178151bd1e5684fef60b8be (patch)
treed5a3e4f6d67596a9f7798d05d272e310a9aab29c /test/ipa/meson.build
parentc1bbbd3b5b4706a31a7505fdd9ad65786764e2d7 (diff)
test: ipa: add IPAModule tests
Add tests to test the the IPAModule class, for loading the IPA module info from IPA module .so shared objects, with modules written in both C and C++. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/ipa/meson.build')
-rw-r--r--test/ipa/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/ipa/meson.build b/test/ipa/meson.build
new file mode 100644
index 00000000..6df0671b
--- /dev/null
+++ b/test/ipa/meson.build
@@ -0,0 +1,21 @@
+ipa_modules_sources = [
+ ['ipa-dummy-c', 'shared_test.c'],
+ ['ipa-dummy-cpp', 'shared_test.cpp'],
+]
+
+foreach m : ipa_modules_sources
+ shared_library(m, name_prefix: '',
+ include_directories: test_includes_public)
+endforeach
+
+ipa_test = [
+ ['ipa_test', 'ipa_test.cpp'],
+]
+
+foreach t : ipa_test
+ exe = executable(t[0], t[1],
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+
+ test(t[0], exe, suite: 'ipa', is_parallel: false)
+endforeach