summaryrefslogtreecommitdiff
path: root/test/ipa/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-10-27 08:04:12 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-11-20 21:48:06 +0200
commit870f2d3b1fcb85e4bf2484b32c5a03d39334e822 (patch)
tree6f1ee99fab89ba088f810db786e4e08d83f7595f /test/ipa/meson.build
parentd7e0985ce13d094608bec9b496873ae0361ea87d (diff)
test: ipa: Add IPA wrappers test
Wrap an IPAInterface in an IPAInterfaceWrapper in an IPAContextWrapper, and verify that the translation between C and C++ APIs work correctly. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/ipa/meson.build')
-rw-r--r--test/ipa/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/ipa/meson.build b/test/ipa/meson.build
index c501fcf9..f925c50a 100644
--- a/test/ipa/meson.build
+++ b/test/ipa/meson.build
@@ -1,13 +1,14 @@
ipa_test = [
['ipa_module_test', 'ipa_module_test.cpp'],
['ipa_interface_test', 'ipa_interface_test.cpp'],
+ ['ipa_wrappers_test', 'ipa_wrappers_test.cpp'],
]
foreach t : ipa_test
exe = executable(t[0], t[1],
dependencies : libcamera_dep,
- link_with : test_libraries,
- include_directories : test_includes_internal)
+ link_with : [libipa, test_libraries],
+ include_directories : [libipa_includes, test_includes_internal])
test(t[0], exe, suite : 'ipa')
endforeach