summaryrefslogtreecommitdiff
path: root/test/gstreamer/meson.build
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2024-01-19 15:08:48 -0500
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-01-23 02:21:39 +0200
commit484c86ac6569363e539ad2729409ece4f161b802 (patch)
treeeabbdb5dbed82f058b460586df5fb6a47a027065 /test/gstreamer/meson.build
parentebc396fc7aef5a3a07a0ec2c32ab5ae72d31c513 (diff)
test: gstreamer: Use env instead of registry edit
Instead of editing the registry, use gst_env variable provided by the plugin and already used as part of the devenv shell. This reduces the complexity of the C++ test code. Signed-off-by: Nicolas Dufresne <nicolas.dufresne@collabora.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/gstreamer/meson.build')
-rw-r--r--test/gstreamer/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/gstreamer/meson.build b/test/gstreamer/meson.build
index a5c003b6..f3ba5a23 100644
--- a/test/gstreamer/meson.build
+++ b/test/gstreamer/meson.build
@@ -17,5 +17,5 @@ foreach test : gstreamer_tests
link_with : test_libraries,
include_directories : test_includes_internal)
- test(test['name'], exe, suite : 'gstreamer', is_parallel : false)
+ test(test['name'], exe, suite : 'gstreamer', is_parallel : false, env : gst_env)
endforeach