summaryrefslogtreecommitdiff
path: root/src/v4l2/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-07 20:02:29 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-08 19:34:05 +0200
commit20fb72a56eb3afe347ac058c13b8c84fbff1ed40 (patch)
treec27b8f0244c3572f0a55822ce9ab09110e0ea5a2 /src/v4l2/meson.build
parentf41627121287cec4b2f5a590386d97903e0dd381 (diff)
v4l2: v4l2_compat: Use correct libcamera_dep dependency
The v4l2-compat shared library is declared as depending on libcamera_deps. This is not correct, as libcamera_deps contains the dependencies of libcamera itself. The correct dependency for users of libcamera is libcamera_dep. Fixing this allows dropping libcamera_includes from the list of includes required by v4l2-compat, and libcamera from the link_with list, as they are already contained in libcamera_dep. We however need to add an explicit dependency on libdl which was previously provided by libcamera_deps. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/v4l2/meson.build')
-rw-r--r--src/v4l2/meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/v4l2/meson.build b/src/v4l2/meson.build
index 14ee3594..efab968f 100644
--- a/src/v4l2/meson.build
+++ b/src/v4l2/meson.build
@@ -5,11 +5,6 @@ v4l2_compat_sources = files([
'v4l2_compat_manager.cpp',
])
-v4l2_compat_includes = [
- libcamera_includes,
- libcamera_internal_includes,
-]
-
v4l2_compat_cpp_args = [
# Meson enables large file support unconditionally, which redirect file
# operations to 64-bit versions. This results in some symbols being
@@ -25,7 +20,6 @@ v4l2_compat = shared_library('v4l2-compat',
v4l2_compat_sources,
name_prefix : '',
install : true,
- link_with : libcamera,
- include_directories : v4l2_compat_includes,
- dependencies : libcamera_deps,
+ include_directories : libcamera_internal_includes,
+ dependencies : [ libcamera_dep, libdl ],
cpp_args : v4l2_compat_cpp_args)