summaryrefslogtreecommitdiff
path: root/src/v4l2/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2020-06-08 19:36:12 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2020-06-19 20:21:00 +0900
commit1023107b6405266d480ce9c08cd82a30449a505b (patch)
treea09a761ac510ef61b9b17ae912466e5e1519456a /src/v4l2/meson.build
parentee5dc92dc19965f12b950aa52ad231e192086711 (diff)
v4l2: v4l2_compat: Intercept open64, openat64, and mmap64
Some applications (eg. Firefox, Google Chrome, Skype) use open64, openat64, and mmap64 instead of their non-64 versions that we currently intercept. Intercept these calls as well. _LARGEFILE64_SOURCE needs to be set so that the 64-bit symbols are available and not synonymous to the non-64-bit versions on 64-bit systems. Also, since we set _FILE_OFFSET_BITS to 32 to force the various open and mmap symbols that we export to not be the 64-bit versions, our dlsym to get the original open and mmap calls will not automatically be converted to their 64-bit versions. Since we intercept both 32-bit and 64-bit versions of open and mmap, we should be using the 64-bit version to service both. Fetch the 64-bit versions of openat and mmap directly. musl defines the 64-bit symbols as macros that are equivalent to the non-64-bit symbols, so we put compile guards that check if the 64-bit symbols are defined. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Tested-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> # Compile with musl Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/v4l2/meson.build')
-rw-r--r--src/v4l2/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/v4l2/meson.build b/src/v4l2/meson.build
index 0fb941ea..f2e4aaf2 100644
--- a/src/v4l2/meson.build
+++ b/src/v4l2/meson.build
@@ -15,6 +15,7 @@ v4l2_compat_cpp_args = [
# file operations, disable transparent large file support.
'-U_FILE_OFFSET_BITS',
'-D_FILE_OFFSET_BITS=32',
+ '-D_LARGEFILE64_SOURCE',
'-fvisibility=hidden',
]