summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-05-01 03:19:19 +0200
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-05-02 14:46:17 +0200
commitdb7235b7141aa4e2922827b4678e25da4faa8c5d (patch)
treede98aff4cca9159255d5f9178e291d59932365fd /src/qcam/meson.build
parent55d5e3e59f48ed251da5953657570c2f7c50a553 (diff)
qcam: Add DNGWriter
Add an initial DNG file writer. The writer can only deal with a small set of pixel formats. The generated file is consumable by standard tools. The writer needs to be extended to write more metadata to the generated file. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build20
1 files changed, 17 insertions, 3 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index 895264be..949ef614 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -1,9 +1,9 @@
qcam_sources = files([
+ '../cam/options.cpp',
+ '../cam/stream_options.cpp',
'format_converter.cpp',
'main.cpp',
'main_window.cpp',
- '../cam/options.cpp',
- '../cam/stream_options.cpp',
'viewfinder.cpp',
])
@@ -23,8 +23,22 @@ qt5_dep = dependency('qt5',
required : false)
if qt5_dep.found()
+ qcam_deps = [
+ libcamera_dep,
+ qt5_dep,
+ ]
+
qt5_cpp_args = [ '-DQT_NO_KEYWORDS' ]
+ tiff_dep = dependency('libtiff-4', required : false)
+ if tiff_dep.found()
+ qt5_cpp_args += [ '-DHAVE_TIFF' ]
+ qcam_deps += [ tiff_dep ]
+ qcam_sources += files([
+ 'dng_writer.cpp',
+ ])
+ endif
+
# gcc 9 introduced a deprecated-copy warning that is triggered by Qt until
# Qt 5.13. clang 10 introduced the same warning, but detects more issues
# that are not fixed in Qt yet. Disable the warning manually in both cases.
@@ -40,6 +54,6 @@ if qt5_dep.found()
qcam = executable('qcam', qcam_sources, resources,
install : true,
- dependencies : [libcamera_dep, qt5_dep],
+ dependencies : qcam_deps,
cpp_args : qt5_cpp_args)
endif