summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2019-04-03 17:03:45 +0700
committerKieran Bingham <kieran.bingham@ideasonboard.com>2019-04-03 18:03:56 +0700
commitd5ca33f6c7b0cd1ca20ec5dc7131aeedf1503080 (patch)
treed840313afee1f3f3ca5250af6ffba77ee52ba53e /src/qcam/meson.build
parent78552c818b8b9f9ea3b1a244e4d5ba2c86b07ce6 (diff)
qcam: meson: Use pkg-config method for qt5 dependencies
Meson searches for qmake to determine if QT5 is available to support the optional qcam component. When cross compiling, meson can incorrectly identify the host qmake which will cause incorrect linkage and usage of system headers. Set the dependency method to specify pkg-config which resolves the issue. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index 8a71cda3..3d8b1b3b 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -8,7 +8,10 @@ qcam_sources = files([
])
import('qt5')
-qt5_dep = dependency('qt5', modules: ['Core', 'Gui', 'Widgets'], required : false)
+qt5_dep = dependency('qt5',
+ method : 'pkg-config',
+ modules : ['Core', 'Gui', 'Widgets'],
+ required : false)
if qt5_dep.found()
qcam = executable('qcam', qcam_sources,